Subject: Newer kernels and system lockups
To: None <>
From: Andrew Cherry <>
List: amiga-dev
Date: 08/20/1994 22:57:49
A while back, I reported having problems with random system lockups,
seemingly related to disk activity.  I still have such problems;
I'm using the current kernel compiled from sun-lamp sources.  I
have some more information that may (or may not!) be useful.

I found that the lockups, though mostly occurring at random times,
occur more frequently while accessing my adosfs partitions.  More
specifically, I have been able to consistently get the lockups
to happen by running zip (an Infocom interpreter) on an infocom
data file on an ados partition.  (Just because I'm using NetBSD
doesn't mean I have to give up Infocom games :) ).  Anyway,
I usually work in X, but I tried it once from the console instead,
and got a kernel panic.  (Apparently, this appears as a simple
lockup when working within X, since the console is not directly

The panic was caused by:

trap: bad kernel access at 10
trap type 8, code 485, v=10
pid=214, etc etc etc..

Here is the result from a trace:

db> trace
_Debugger(20cec,b3c6d,fffffe98,8,fffffc9c) + 6
_panic(b3c6d,0,fffffe98,8,fffffc96) + 6
_panictrap(8,485,10,fffffd3c,b3f57,10) + 60
_trapmmufault(8,485,10,fffffd3c,b3f57,10) + 60
_trap(8,485,10) + 350
_brelse(0,0,200,200,0) + e0
_adosfs_bmap(fffffe1c) + 18e
_adosfs_strategy(fffffe48) + 78
_bread(563300,0,200,ffffffff,fffffe94) + 7a
_adosfs_read(fffffecc,3,1,dc,206dd4a) + e0
_vn_read(5bed80,ffffff24,5c8b80) + 98
_read(5cae00,ffffff84,ffffff7c) + a2
_syscall(3) + 138
_trap0() + e

Hope I read my handwriting correctly. :)

Sorry that I haven't given a more standard way of reproducing the
error, but the Infocom interpreter is the only thing I have tried
that consistently causes a panic (but only when accessing the ados
partitions; if I copy the data file over to a BSD partition and work
from there, things work fine.  Much faster too, of course.)

I don't know if this is related to the other crashes I've reported;
most of them have occurred when working on NetBSD partitions, primarily
when writing (most of those crashes seem to occur when emacs is
autosaving).  At any rate, it's certainly something that ought
to be looked into. 

The other system lockups I've had during disk accesses are probably
also producing kernel panics that are not visible due to the X server
running.  But aside from the above, I have had no success at forcing
crashes at the console.  They never happen when you *want* them to,
of course.

My setup:
A2000, 1MB CHIP
G-Force 68040, 12MB 32-bit RAM, Series II SCSI
Seagate ST31200N 1 gig SCSI-2 drive
Archive Viper 2525S

Oh, and the Viper is a recent addition; I've had the crashes
before I got the Viper.  (In fact, the crashes were the motivation to
buy a tape drive :) ).

-Andrew Cherry