tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: RFC: BUFQ_REVOKE()



On Sat, Apr 12, 2008 at 05:49:33PM -0700, Jason Thorpe wrote:
> I prefer the name BUFQ_CANCEL().
> 
> How is it to be called?  What are the arguments?

well, i was thinking (to use your name suggestion) of

        BUFQ_CANCEL(struct bufq_state *, struct buf *buf)

and as a macro to 

        struct buf *(*bq_cancel)(struct bufq_state *, struct buf *buf)

inside struct bufq_state, so each bufq dicipline can implement it the 
easiest way.

Initially i was also thinking of bufq_move(struct bufq_state *, struct 
bufq_state *, struct buf *buf) but bufq_move seems to be in use to move 
*all* bufs from queue1 to queue2.... maybe a rename would be an idea?

or use bufq_move2(struct bufq_state *, struct bufq_state *, struct buf 
*buf) and rename bufq_move() to bufq_moveall()

With regards,
Reinoud

Attachment: pgpcmdEEBRHcd.pgp
Description: PGP signature



Home | Main Index | Thread Index | Old Index