tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Updating libdrm and xf86-video-ati?

Bernd Ernesti wrote:
>On Thu, Sep 20, 2012 at 11:03:19PM +0200, Thomas Klausner wrote:
>> Hi!
>> Robert Swindells found out that updating xf86-video-ati to 6.14.6 gets
>> rid of some display problems introduced with the latest cairo.
>> The release notes claim that that version needs libdrm-2.4.36 though,
>> and xsrc only contains 2.4.20.
>> Does anyone see a problem with updating the two?
>I updated xf86-video-ati here and it works fine without the libdrm update.
>The generated config.h needs some adjustment for the wrong libdrm version.
>And the debug messages in the driver are annoying if you switch the console
>but that is also the case for the current version. They only added some more
>debug messages.
>The updated libdrm requirment looked for me only for KMS, which we do
>not use.

The detailed list of changes in the release note suggest that the updated
libdrm is only needed for KMS.

I don't see any difference in the behaviour of glxgears or glxinfo
between 6.14.4 and 6.14.6.

>I plan to update the driver but that has to wait until Sunday.

I can update it sooner if people want me to.

Robert Swindells

Home | Main Index | Thread Index | Old Index