tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ATI Radeon HD 4350 - no Xv - drm(4) support missing?

On Mon, May 11, 2009 at 11:41:53PM +0200, Thomas Klausner wrote:
> Hi!
> Yesterday I tried a ATI Radeon HD 4350 on NetBSD with the
> xf86-video-radeonhd-1.2.5 driver from pkgsrc.
> Basic 2D works fine. However, there is no Xv support.
> I read up a bit on it, and it seems that the driver needs DRM support
> in the kernel for Xv:


> So I added
> radeondrm* at vga?
> options DRM_EXTERNAL
> to my kernel config, compiled, found that I need agp as well, added
> agp*    at pchb?
> as well, compiled, and rebooted.
> "dmesg | grep -i -e vga -e drm -e agp" then said:
> vga0 at pci7 dev 0 function 0: ATI Technologies product 0x954f (rev. 0x00)
> wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)
> drm at vga0 not configured
> Still no XV, as expected.

Yeah, because our source code doesn't handle the 'new' generation of chips.

> Suggestions for a next step?

The drm code needs to be updated, but thats not all. The mesa libraries
needs to be updated too, which also means more other updates for libdrm
and the xserver.


Home | Main Index | Thread Index | Old Index