tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xorg for alpha

On Wed, Jan 14, 2009 at 12:53:54PM +0100, Manuel Bouyer wrote:
> > I don't think Xorg's alpha-specific PCI support code works right on  
> > NetBSD
> It looks a lot like what we had in your XFree86 tree; and this one works
> at last on a PWS500 (I couldn't test xorg on a PWS500 yet; I have to find
> a battery to make it work again). The same XFree86 has issues on XP1000,
> so it may be a Tsunami-specific issue.
> > - I think you should do as sparc64 and the powerpc ports do -  
> > use netbsdPci.c / ppc_video.c and mmap PCI resources through /dev/ 
> > ttyE0 at offset == bus address. Much less hassle.
> How does it work with multiple VGA adapters ? Also, alpha support
> graphic adapters which are not VGA (like the TGA for example)

Also, on non-BWX platforms, alpha needs 2 mappings: sparse and
dense. I'm not sure the /dev/ttyE0 would handle it.

And I've found the issue: our tsunami driver doens't export sparse
and dense mappings, because this chipset doesn't support sparse mappings.
So abw[] has only one element on tsunami, and memory_base() reads outside of
the array. Using abw[0] instead of abw[1] when abw_count is 1 gives the
correct result, and gives a working glint server on XP1000.

I'll try the XP1000 with other video adapters I have in hands, and
also the PWS500 if I can convice it to switch away from alphabios,
but I'm quite confident that we now have a working xorg even on
EV6 systems.

what's missing now is a port of the XdecNetBSD and XalphaNetBSD servers,
I'm not sure how much work it requires, and I've no way to test theses

Manuel Bouyer, LIP6, Universite Paris VI.  
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index