tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NV dual monitor setup ...crashing.

On Mon, Oct 27, 2008 at 08:41:11PM -0400, Martin S. Weber wrote:
> Yo,
> I've tried today to setup my new machine (a nice piece of dell t5400)
> with two monitors. It has a single Nvidia with two Y plugs so you can
> set it up with up to four monitors. I wanted to run two independent
> screens on it. Xorg -configure (pkgsrc-2008Q3) spit out a config file
> with two 'Device', 'Monitor' and 'Screen' sections ... which sadly
> will crash the X-Server. I see both monitors going on for a moment,
> but then that's it.

I have tried different combinations of plugging the monitors into the
same card, using the DualHead and DualLinkModes options, increasing
the virtual size etc. Basically the story is: As soon as I use the
second card in parallel, the server crashes in the RandR1.2 Init.

As a further datapoint, the X.Org will find two cards while netbsd
only finds one of them. The Root console is on something will
call PCI:2:0:0 while the "second" card is PCI:1:0:0.

I have tried (and failed) to debug this (printf debugging), maybe
I should try with not-from-pkgsrc; I'm not making a great progress

So I've contacted the maintainer of the 'nv' driver on behalf of
X.Org, asking for further input. He replies that he hasn't tested
it (dual head support) but he's just using plain RandR and thus the
fault must lie at the X.Org people. He suggests going to the xorg lists.

Now I know one thing for sure: When I go to the Xorg list they will
tell me that it's either netbsd's fault, or the nv driver. So to collect
some more data:

Has anybody of you used some version of NVidia cards with the nv driver
in a dual head setting successfully? If so, which card, version of
and NetBSD version would be nice to know I guess. Because if that's working,
the bug is likely to be in my specific card or PCI probe.

Has anybody of you used the 2008Q3 version of modular-xorg with any card
with dual head support as brought to you via RandR? Because if that's
working, the bug is likely to be in NetBSD or nv (or its combination).

I at least wanna rule out one of the unknown factors and I admittedly have
most trust in the technical expertise of the NetBSD developers and X 

Regards & thanks in advance,


Home | Main Index | Thread Index | Old Index