Subject: Re: ATI TV-OUT support ?
To: Joel CARNAT <>
From: Eric Anholt <>
List: tech-x11
Date: 11/26/2007 11:27:26
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

On Sun, 2007-11-25 at 17:29 +0100, Joel CARNAT wrote:
> Hello,
> I've tried to configure TV-Out on an old laptop I have.
> It runs NetBSD 4.0_RC4 and ships with an "ATI Technologies Radeon Mobilit=
> M6 LY (rev 0x00).
> I've tried using the native XFree86 and Xorg (xserver-1.2 and xserver-1.3=
> but I just can't get tvout to work.
> atitvout works, a detect says:
> CRT is attached.
> TV is attached via Composite
> I've tried various parameters and Modes (according to stuff I found via
> Google) but it seems the GATOS extension never works. The only case when =
> can have TV out is, from the console, running "atitvout -f t", then start
> XFree86 with the vesa driver, in 800x600. But the quality is far from wha=
> it is on the Windows instance.
> The laptop has a dual-boot WindowsXP/NetBSD, and it works OK on Windows,
> so I guess my cables are OK.
> Has anyone succeeded in using TV-out with an ATI driver ?
> If so, which software is recommended (NetBSD version and XFree/Xorg) ?
> And what are the magical X.conf parameters ?

For ATI TV-out, you want to be using xf86-video-ati from upstream, or
maybe one of their recent release candidates  (6.7.195 or newer). Then
it should be automatically configured, or configurable at runtime with

Eric Anholt                                  

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.4.7 (FreeBSD)