Subject: Re: DRI problems (but with an "experimental" config.)
To: Chavdar Ivanov <>
From: Vincent <>
List: tech-x11
Date: 10/28/2007 15:43:20
Chavdar Ivanov wrote:

> Well, it's not the same setup, but the end result is :- my laptop with
> an Intel 945GM is fine with 4.99.33 (I can't tell right now the
> versions of modular-xorg and the rest, but it should be 1.3; I run 1.4
> only at work). With a 4.99.34 kernel from 3-4 days ago it behaves the
> described way - glxgears works for a few seconds. In both cases I use

Thanks a lot for your input. I was suspecting the 1.4 xorg code, and was 
about to revert to 1.3 with the old radeon driver to figure out. So it 
is rather caused by a kernel update. I'll try to figure out what has 
changed betwixt 4.99.33 and 4.99.34

> On the office machine I tried some times ago a Radeon 9800SE; glxinfo
> reported DRM enabled as it should be, glxgears froze Xorg hard, but
> not the system, which was still accessible via ssh.

Glxinfo has worked only once on my machine. Since almost three or four 
month, I systematically get "Direct rendering: no", albeit glxgears 
reports figures that are only compatible with DRI.

>> How can I figure out what's wrong? In other terms, where can I put
>> traces to help understand why it crashes?
> I couldn't figure this out as well; I'd be interested in an approach to do so.

If the kernel is responsible, I think there is a debug flag like "option 
DRMDEBUG" that could be added.