Subject: Re: DRI problems (but with an "experimental" config.)
To: Vincent <>
From: Chavdar Ivanov <>
List: tech-x11
Date: 10/28/2007 11:26:42
On 28/10/2007, Vincent <> wrote:
> Hi there,
> I have a recurrent problem with the DRI since I moved to a "quite
> experimental" configuration: modular-xorg v1.4, xf-video-ati 6.7.195 and
> libdrm 2.3.1, all of these (and the kernel also) compiled with gcc 4.2.
> When I test the DRI with glxgears, the test goes fine for a few seconds
> at most, then the system hangs (the kernel crashes).

Well, it's not the same setup, but the end result is :- my laptop with
an Intel 945GM is fine with 4.99.33 (I can't tell right now the
versions of modular-xorg and the rest, but it should be 1.3; I run 1.4
only at work). With a 4.99.34 kernel from 3-4 days ago it behaves the
described way - glxgears works for a few seconds. In both cases I use
Yorick Hardy's patches for DRM and 945GM. The funny thing is that the
same kernel works fine from my external USB2 test copy of -current. I
meant to compare the differences between the packages installed on
both, but haven't done it yet.

On the office machine I tried some times ago a Radeon 9800SE; glxinfo
reported DRM enabled as it should be, glxgears froze Xorg hard, but
not the system, which was still accessible via ssh.

> How can I figure out what's wrong? In other terms, where can I put
> traces to help understand why it crashes?

I couldn't figure this out as well; I'd be interested in an approach to do so.

> Thanks!
> Vincent

/dev/random says:
	Did you expect mere proof to sway my opinion?
Chavdar Ivanov   | Talbot Way, Small Heath Business Park
Delcam UK        | Birmingham B10 0HJ, United Kingdom
Customer Support | (+44)121-6831014