Subject: Radeon X850 DRI still not working
To: None <>
From: Arto Huusko <>
List: tech-x11
Date: 05/30/2007 00:10:48
Hi list,

I just tried DRI with Radeon X850 after installing new version
of kernel, MesaLib-dri and modular-xorg-server, but it still
is not working.

The problem is the same as before: the DRI/DRM modules seem are
loaded OK, but actually trying to do anything, such as running
glxgears results in the message:

drmRadeonCmdBuffer: -22 (exiting)

glxinfo works without a problem, and reports the DRI R300 module.

This time around, however, the kernel prints the following messages and
errors when X is first loaded and glxgears is run:

info: [drm] Setting GART location based on new memory map
info: [drm] Loading R300 Microcode
info: [drm] writeback test failed
radeondrm0: interrupting at ioapic0 pin 16 (irq 11)
error: [drm:pid14618:r300_emit_carefully_checked_packet0] *ERROR* Offset
failed range check (reg=4e28 sz=1)
error: [drm:pid14618:r300_do_cp_cmdbuf] *ERROR* r300_emit_packet0 failed

I can try this with hw.dri.debug=1 and see what it says, if that
would be any help?

During boot, AGP and the Radeon are probed as:

agp0 at pchb0 (v3): aperture at 0xf8000000, size 0xf000000
radeondrm0 at vga0
info: [drm] ATI Radeon R481 X850 Pro (unit 0)
[drm:pid0:radeon_driver_load] AGP card detected
[drm:pid0:drm_agp_init] agp_available = 1
info: [drm] AGP at 0xf8000000 64MB
[drm:pid0:drm_mtrr_add] offset=f8000000 size=67108864
[drm:pid0:drm_ctxbitmap_next] drm_ctxbitmap_next bit : 0
[drm:pid0:drm_ctxbitmap_init] drm_ctxbitmap_init : 0
info: [drm] Initialized radeon 1.25.0 20060524