Subject: Re: xorg-server/Mesa issues
To: Blair Sadewitz <>
From: Chavdar Ivanov <>
List: tech-x11
Date: 05/26/2007 18:57:40
On 26/05/07, Blair Sadewitz <> wrote:
> Chavdar brought up something which I neglected to mention:  If you're
> experiencing problems, it is imperative that you synchronize Mesa
> versions between server and libraries, e.g. use 6.5.3.  I suppose to
> make this easier I'll commit changes to the glu/glut packages, etc.

I am not sure about the Mesa state on my system right now. As I
mentioned, I got rid of everything before going ahead with the latest
packages. Something along the lines brought back mesa-dri, so I now
have both MesaLib-6.5.3 (from MesaLib-dri package) and mesa-dri (which
is 6.5.2). The links - and - point to, which is from mesa-dri (therefore 6.5.2) and not to (which is from 6.5.3 - notice the version number

Anyway, as it seems to be working fine right now, I am not touching it for now.

> Also, you should use the latest video drivers.

May be my manual xf86-video-intel installation helped here, I don't
know. I don't seem to see any package for it.

> For compiz, make sure the LIBGL_ALWAYS_INDIRECT environment variable
> is set [to 1] before you start it.  In addition, you may need to add
> ${LOCALBASE}/lib/compiz to LD_LIBRARY_PATH.  There's a thread a few
> months back where jmcneill@ posted a simple startup script for compiz.

I will try this later.

> Glad to hear someone got beryl to work; I thought my packages might've
> been busted.

And seems to be working very well, mind you... I've got one of the
Vista lookalike Emerald themes and bragging around ... fun with all
the weird effects etc. Doesn't take much CPU either.

>  After all, I somewhat hastily made them at some ungodly
> hour of the early morning. ;)  Were you using my pkgsrc packages, or
> did you install it yourself?

Yours with the exception of the themes. Initially I did not get window
decorations, probably because was running it with 16-bit colour; later
I installed & ran manually heliodor and it seems to fix it; now it
just works out from the menu.

> Regarding i915, there are  issues with our agp driver.  I had made a
> patch for it, but I was getting the aperture size from the wrong BAR,
> so I have to refactor that. I just haven't had the time lately (and I
> don't really use i915 hardware myself); if someone wants to work on
> this, send me an email, and I'll outline the things that need to be
> fixed.

I tried your patch, which didn't work for me; I had already installed
Yorick's patches for these, which I think solved it for me.

> When Mesa 7.0 comes out, additional bugs may be fixed.
> Regards,
> --Blair


Chavdar Ivanov