Subject: Re: MesaLib-dri 6.5.3+patches package in pkgsrc-wip
To: Ahmad M. Afuni <>
From: Chavdar Ivanov <>
List: tech-x11
Date: 05/26/2007 00:53:35
On 25/05/07, Ahmad M. Afuni <> wrote:
> I guess I'll try them out now then.

I did.

> /me hopes DRI finally works.

It worked before for me with Xorg7.2+Mesa6.5.2 (I had to disable
AIGLX). Now it works with AIGLX as well.

> Ahmad
> On 5/26/07, Blair Sadewitz <> wrote:
> > OK, the keyboard problems can be caused by PCVT_SUPPORT not being
> > defined by configure (in config.h).  At least, this is what seemed to
> > cause this problem when I had it.  I just re-committed all of the
> > patches for the Xserver, so it should work.  The new Mesa is in
> > wip/MesaLib-dri.

The problem with the VT support has been fixed, thanks.

I am not quite sure about all the versions of mesa/modular-xorg in
wip. What I did was:

  - removed modular-xorg (7.2)
  - removed all traces of mesa and glu
  - installed wip/modular-xorg-server-mesa653
  - installed wip/MesaLib-dri (first without, then with the x86 option)

On top of that I decided to switch to the latest xf86-video-intel
driver, which also worked fine.

The OpenGL performance was slightly better than before; this is after
all Intel 945GM, so I got ~186 fps glxgears in full screen mode
(1024x768). This went up to about 280 fps after I tweaked xorg.conf a
bit (I haven't investigated it step by step; it is possibly mainly due
to the switch to 16bit mode, but I added also
        Option "AperTexSize" "65536"
        Option "AccelMethod" "EXA"

There are a few things to sort out (if possible). Some programs give me:

% /usr/pkg/libexec/xscreensaver/atlantis
libGL warning: 3D driver claims to not support visual 0x63

(atlantis displays just a blank screen). blender gives the same
message, but otherwise works fine.

Compiz also does not work still:

% compiz --replace gconf
libGL warning: 3D driver claims to not support visual 0x63
compiz: GLX_EXT_texture_from_pixmap is not supported by direct
rendering context, trying indirect rendering context instead
compiz: GLX_EXT_texture_from_pixmap is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0
zsh: exit 1     compiz --replace gconf

> >
> > It all should be in wip now, please let me know if there's any more trouble.
> >
> > Regards,
> >
> > --Blair
> >

Chavdar Ivanov