Subject: xorg-server-1.3.0 + Mesa 6.5.3 would not build + dri interrupt level
To: None <>
From: Vincent <>
List: tech-x11
Date: 05/18/2007 08:32:28
Hi there,

first of all, thanks Blair for all the efforts on the Xorg+Mesa set.

I've tried to build the modular-xorg-server-Mesa653 and it doesn't work. 
The configure process complains about not finding Mesa:

Creating destination directories for mesa module ...
    error:   Source directory 
does not exist
configure: error: Failed to link Mesa source tree.  Please specify a 
proper path to Mesa sources, or disable GLX.

Needless to say, I tried to create a void array_cache directory in the 
tree, but it solves nothing since the link script expects some files to 
be stored in it. Rubbing out the corresponding function in the script 
leads only to a farther (and further) error some place else.

I'm wondering if some source has changed since the package was created?

Thanks for any help

PS: Other problem — the dri kernel module and the ath driver of my WiFi 
card interrupts on the same level, and that seems to crash the kernel 
randomly, besides causing regular "ath timeout" errors. Is there any way 
to alter the interrupt level of the DRI?