Subject: Re: xorg-server-1.3.0 + Mesa 6.5.3 would not build + dri interrupt level
To: Blair Sadewitz <>
From: None <>
List: tech-x11
Date: 05/18/2007 09:50:20

> Do you have the 'dri' option set?  I know that others have used that
> package, and would be very confused if it suddenly stopped working, as
> I haven't committed any changes to it.

Yup. Indeed, I first built xorg-1.3.0 without dri being set, and it works fine,
but it does not support OpenGL at all, not even in software. I assume this is
because it lacks drm support in the server, so that the Mesa-dri libraries
cannot work properly. I'd have to switch back to "software only" Mesa, something
I does not intend to do execpt if I get more or less screwed.

I shall have a look on the xorg sources, maybe they just replaced the
version by something newer without altering numbering?

> As for the interrupt problem:  This isn't a DRI issue. You need to
> change the interrupt of your VGA card.  You can try moving it to a
> different slot, fiddling with BIOS options, or enabling PCI_INTR_FIXUP
> in the kernel.  If your machine supports ACPI, try using that first.
> If that doesn't work, you can always try it with options PCIBIOS.

I'll try that, thanks for the trick. I'll keep you posted anyhow.