Subject: mgadrm && xorg-server 1.3.0
To: None <>
From: theglass <>
List: tech-x11
Date: 05/10/2007 16:58:38
hi all,

I've been trying to make modular-xorg-server work with
DRI/DRM on my system (AMD K6-2 + Matrox AGP G400 on board), 
which runs a -current kernel (4.99.18).
The DRM loads fine, as i can see from the dmesg output,
but, just after a starting 'Xorg &', I get a blank screen.
Then the kernel probably enters in ddb and I'm only able to blindly type
'reboot' (no crash dump nor msgbuf output, due to some device issues, sorry). 

At least, I can take a look at xorgserver's log, which suggests 
some (DMA?) memory mapping issues:
(II) MGA(0): [drm] DRM interface version 1.2
(II) MGA(0): [drm] created "mga" driver at busid "pci:0000:01:00.0"
(II) MGA(0): [drm] added 8192 byte SAREA at 0xcfe77000
(II) MGA(0): [drm] mapped SAREA 0xcfe77000 to 0xb971f000
The log is the usual Xorg.log, except that it abruptly
stops here, when the kernel jumps into ddb.

I've been getting better results after applying the bus_dma patch
by jmcneil ( ) :
which makes the DRI load correctly (but the server keep on
hanging..see the Xorg.0.log attached).
Comparing this session's Xorg.log to a session without DRI's
it seems the server dies in another BusID scan, just before
loading the GLcore module (..or when loading this module?).

I tried various different combinations of options: disabling AIGLX, 
using OldDmaInit and UsePciDma from the mga driver (which seem to be 
similar to radeon's BusType "PCI", nominated in the previos threads)
but none of them solved.

So far, i've been using mesa-dri-6.5.2 and modular-xorg-server ( 
both with EXA acceleration (which is reported to be experimental),
and traditional XAA, but i didn't notice any difference.

have you got any hints? or anything else that can be related to?

I saw a previous thread, which i don't recall its name atm, regarding
mga/xorg. maybe the issues there claimed can be solved by appliyng that patch.

thanks all,


P.S. is there any topic concerning the aperture driver? my xorg-server 
has been compiled to support it, and i'd like to know if it supports or
conflicts with the DRI. thanks again.