Subject: Re: libGLU in mesa-dri
To: Blair Sadewitz <>
From: Eric Anholt <>
List: tech-x11
Date: 04/17/2007 11:46:34
Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

On Tue, 2007-04-17 at 12:31 -0400, Blair Sadewitz wrote:
> Aah, thanks for the heads up.  Are you doing this in FreeBSD?  I was
> wondering the other day about whether or not we should try to merge in
> any feature enhancements/bug fixes from the Mesa master branch.  Is
> there anything else you'd recommend?

Not currently, but we haven't even got modular integrated yet.  I've
been leaving that up to the guys that have been working on that
integration, and I'm hoping to take more of a role in FreeBSD stuff once
modular actually gets into the tree.

> Also, I'm having trouble with the i915 driver (not i915tex, I think
> our kernel drm is too old).  It worked previously, but as of server
> .905 and driver .94, when I start Xorg, the screen flashes and then
> goes blank.  Most of the time I can shut the system down via an ACPI
> button event, but occasionally I get a page fault (IIRC), which makes
> me think something's going wrong with the memory allocation (AFAIK we
> still need to bus_dma-ify a lot of the DRM code).  The server leaves
> behind no logs.  I tried running it with NoTrapSignals to get it to
> segfault and maybe give me a clue as to what's going on, but no dice.
> The  DRM code doesn't complain about anything, either.
> On the other hand, my R423 (r300 driver) works (even with #define

First of all, if you're just starting Xorg, you shouldn't be having any
issues related to your 3D driver.  You can put Option "AIGLX" "Disable"
in the ServerFlags section of xorg.conf to make sure, by not loading the
i915 module at all.

On intel hardware, bus_dma-ification shouldn't do anything as far as
correctness goes -- you don't have any IOMMU to make bus !=3D phys.
However, the new code does probe aperture and GTT sizes differently
(more correctly) on some hardware compared to previous releases.  It
could result in strange issues if your AGP driver doesn't probe things
the same way.

To tell any more, though, I'd need a xorg log with ModeDebug enabled
(with the fs mounted sync, if you're experiencing a full system hang,
which I couldn't tell) and a xorg.conf, probably.

Eric Anholt                                  

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.4.7 (FreeBSD)