Subject: wsfb and WSDISPLAYIO_GINFO and Inappropriate ioctl for device
To: None <>
From: Jeremy C. Reed <>
List: tech-x11
Date: 05/25/2006 22:28:09
I am trying to get modular's wsfb to work on my i386 laptop.

Note: I have not yet tried the NetBSD version with the split out hardware 
cursor support (wsfb_cursor.c), but the code in use for this error appears 
to be the same.

ktrace shows:

1363      1 Xorg     NAMI  "/dev/ttyE0"
1363      1 Xorg     RET   open 8
1363      1 Xorg     CALL  ioctl(8,_IOR('W',0x41,0x10),0x81d1004)
1363      1 Xorg     RET   ioctl -1 errno 25 Inappropriate ioctl for device

X log shows:

(II) wsfb: driver for wsdisplay framebuffer: wsfb
(II) Primary Device is: PCI 01:00:0
(II) wsfb(0): using default device
(II) Running in FRAMEBUFFER Mode
(EE) wsfb(0): ioctl WSDISPLAY_GINFO: Inappropriate ioctl for device
(II) UnloadModule: "wsfb"

And dmesg has:

vga1 at pci1 dev 0 function 0: VIA Technologies VT8623 (Apollo CLE266) VGA
 Controller (rev. 0x03)
wsdisplay0 at vga1 kbdmux 1: console (80x25, vt100 emulation), using wskbd0
wsmux1: connecting to wsdisplay0
wsdisplay0: screen 1 added (80x25, vt100 emulation)
wsdisplay0: screen 2 added (80x25, vt100 emulation)
wsdisplay0: screen 3 added (80x25, vt100 emulation)
wsdisplay0: screen 4 added (80x25, vt100 emulation)

Maybe /dev/ttyE0 is wrong?

I ran Xorg as root while at /dev/console.

I also tried using /dev/ttyE1 (set in xorg.conf) and ran while I was 
logged in at /dev/ttyE1 as a normal user.

 Jeremy C. Reed