Subject: xorg / XFree86 / configure problems
To: None <>
From: Paul Compton <>
List: tech-x11
Date: 05/16/2006 11:19:46

First, let me introduce myself. I'm a sys admin and software developer 
running a small software/consulting firm in Germany. Started on Unix 
on PDP11s and later Solaris on Sun Sparc in the late 80s and early 90s 
- we still had a PDP11 at uni in Tasmania in those days. Since the 
late 90s I've worked mostly in Linux and a little Windows and Mac as 
needed, and for the last 4 years mostly in Gentoo Linux. I finally 
made the switch to NetBSD on two of my machines about three weeks ago. 
So, I'm a newbie, but I have a little understanding of what's going 
on. Unfortunately, so it seems, just a little at this stage.

My problems are all associated with configure scripts, and as far as I 
can tell relate to x11 installation issues, hence the post here. My 
desktop architecture: AMD Athlon XP with 1.5GB RAM. XFree86 (native 
sets) and KDE 3.5.2 built from source.

If I try to install a simple tarball manually (i.e. not as a package), 
I continually come up against a problem that the QT headers cannot be 
found during configuration. I have only tried this on minor packages, 
such as theme engines for KDE, and a couple of small userland apps.

If I try to install using a package created with url2pkg and then 
amended (I am over my head, but I did read the pkgsrc manual four 
times before posting this...) I don't get that far in the 
configuration. It always dies at libXext. First it cannot find a 
connection number from lICE, and then it tells me that a working 
libXext is required.

This libXext problem seems to happen to others too, also on Linux, but 
having googled it for three days I cannot find a suggestion which 
helps me.

Can the problem be a result of using the XFree86 native sets rather 
than installing x11 from pkgsrc? Is there something simple that needs 
to be done here?

Coming from the Linux world I am more familiar and comfortable with 
xorg these days, and have wondered if switching to xorg may resolve 
these problems. But what is involved in making the switch: do I have 
to recompile all my x11-dependent packages, including KDE? And should 
I then remove the native sets once the change is made? Or would this 
change not solve my problems anyway?

Ok, lots of jumping-off points, but my basic problem is getting 
packages to compile for one or two apps that are not in pkgsrc, and 
being able to install smaller scripts without creating packages. I 
would be grateful for any pointers.

Thanks in advance,
Paul Compton