Subject: Can't get X to work on remote desktop with xdm (netbsd-prep)
To: NetBSD Prep Users <>
From: Tim Gallagher <>
List: tech-x11
Date: 02/03/2005 05:16:18
I'm fairly confident that X will not work on an RS6000 machine with a 
GXT800P display adapter.  What I do want to do is compile the X clients 
and send the X output to another system that is running X locally.  I 
allowed the host in my /etc/X0.hosts file, and run xlogo to verify that 
I can display an X client.  I tried running xdm to have a display 
manager answer to any XDMCP requests, after modifying 
/usr/pkg/etc/xorg/xdm/Xservers file and adding the entry ":0 foreign" at 
the end of the file.  I run my X display, which is Cygwin X running 
under Windows 2003, by using the command "X -fullscreen -broadcast :0".  
Nothing honors my X request, and I look on the NetBSD box, and xdm 
crashed.  I look at the log files, and see that xdm attempted to start X 
locally, complained that the file /usr/X11R6/bin/X doesn't exist, and 

Any ideas?

Many thanks for anyone's help,

Tim G