Subject: X and date change causes hang
To: , <>
From: David H.Gutteridge <>
List: tech-x11
Date: 11/17/2004 00:35:27

I've a question about changing a system date while X is running: is there a known interaction problem between X and NetBSD when the date command is used to alter the date?

The other day I experienced a system hang after I changed the date on my iBook laptop (running 1.6.1, with XFree86 4.2.1).  I had taken the battery out and it ended up being behind a few days, so while I was in X, I just opened an XTerm, su'ed to root, and changed the date.  As soon as I hit enter, the screen turned blank and the system because unresponsive.  It was still running, because I could hear the hard drive operating periodically.  The machine returned ping packets, but would not open an ssh session.  After around fifteen minutes, I gave up and reset it.

I tried duplicating this on an i386 system with 2.0_RC4, and the problem also exists there.  In that case, the system freezes for about two minutes, then becomes responsive again.  Remote ssh sessions also freeze, so userland is just unavailable during that time.  I couldn't find any useful information in the logs on what was happening (though I could have missed something).

If I change dates from the console while X isn't running, there is of course no such problem.  I also tried duplicating this on Linux (hppa/Debian 3.0r3/XFree86 4.1.0), and could not.  I tried this with two window managers to see if that made a difference but it didn't (I tried Blackbox and WindowMaker).

I couldn't find any reference to this problem on the site or the internet, I assume it's not considered bone-headed to change dates forward under X?  Has anyone else experienced this problem?


David Gutteridge