Subject: Re: Weird xauth problem
To: None <>
From: Lars Nordlund <>
List: tech-x11
Date: 11/08/2004 23:14:23
Wed 2004-10-13 klockan 21:43 -0400 skrev Thor Lancelot Simon:
> My concern is that this does not seem to be limited to firefox; it
> is just easy to make the symptom *appear* with firefox.  There is
> something about how firefox is using Xlib that causes authentication
> to go all awry, and possibly causes other X server chaos later on,
> including subsequent X servers not starting!
> I don't know what this is.  I do wish I were making any more progress
> figuring it out, but I do not have the time to go tracing through
> firefox, and probably then xlib and the x server, from the failure
> point. :-(


I just got this xauth error on my NetBSD-current running the stock xsrc.
A couple of days ago I configured dual-head and have been running that
without major problems. I did manage to crash the X server by starting
'xlock -mode kumppa'. Have not yet verified if this is repeatable
though. Other than that it seems fairly stable.

Anyway. today I logged in from work and ran an X program through SSH
without problems. After closing this I noticed that xauth complained
when I tried to start another program, or if I got the error message
while the program was exiting. Perhaps it wanted to show some exit
screen and that bounced. I first thought that the problem was that
dhclient had kicked in and changed my local IP address so I logged all
the way out and checked my local machine at work and found out that
everything worked fine there.

When I got home I was unable to start any new X program. I started
fiddling with 'xauth generate' but gave up and recycled my X session.
That seems to have solved the problem for me. Until it happens again, I

I have not been running firefox by the way. I currently surf the www
with mozilla-gtk2.

Best regards
	Lars Nordlund