Subject: Re: XFree86 4.3.0 on VIA M10000
To: Ben Elliston <>
From: Harry Waddell <>
List: tech-x11
Date: 09/04/2003 12:18:07
On Thu, 4 Sep 2003 09:37:39 +1000
Ben Elliston <> wrote:

> Hi
> I am trying to get XFree86 4.3.0 running on my diskless VIA M10000
> (mini ITX) motherboard/video chipset.  I ran X -configure and all
> seemed well.  When I run X, my TFT monitor flashes its LED which I
> believe means it has lost its input signal.

or sometime it means that the signal is out of range. LCD monitors often do
not support modes beyound HorizSync 75. You may want to try a CRT just to
see if there is anything there.

> Has anyone successfully run X on the VIA M10000?  If so, what's the
> trick?  Are there kernel tweaks I might need to try?

I've already tried, and failed. Both with X from the netbsd cvs repository
using the vesa driver and with X compiled from source with VA [castlerock?]
support. Never could get it to work. I'm sue it's do-able, just not by me.

Harry Waddell
Caravan Electronic Publishing