Subject: Re: XF4.3.0 unstable (was Re: Can't use 1600x1280 after upgrade to XF4.3.0)
To: None <>
From: Matthias Scheler <>
List: tech-x11
Date: 08/17/2003 17:11:45
In article <>,
	MLH <> writes:
> Speaking of XFree 4.3.0, something seriously broke between the
> build I did on 19 June 2003 and 12 August 2003 :

> Build Date: 19 June 2003
> Build Date: 12 August 2003

There were no changes to the XFree86 server sources in NetBSD's "xsrc"
source in that time frame.

Do you use NetBSD's sources or the XFree86 ones? Do you have any patches
e.g. the experimental DRI changes in your sources?

Which version of GCC do you use?

> The latest build is fairly unstable with ati video cards.

I guess it's something different e.g. the agp(4) driver. Try disabling
this driver - it doesn't give you any advantage with these cards at
the moment anyway - and see if the problem goes away afterwards.

	Kind regards

Matthias Scheler