Subject: RE: VMware vs. various X servers
To: Marton Fabo <>
From: Sporleder, Matthew (CCI-Atlanta) <>
List: tech-x11
Date: 07/17/2003 13:16:35
Did you try upgrading your X using xsrc?
(I know this doesn't approach either of your problems)

Otherwise, VNC has always been very sensitive to resolution changes for =
You can run vmware natively on netbsd 1.6.1
Its interaction with vnc is not something I would really want to =
experience.  ;)

-----Original Message-----
From: Marton Fabo []
Sent: Thursday, July 17, 2003 1:12 PM
Subject: VMware vs. various X servers


My problem may not be exactly XFree86-related, but falls still close,=20
and perhaps someone around can suggest something.

So, the issue is the following. I'm trying to run VMware on a stock=20
1.6.1 i386 machine. I can't run the provided XFree86 server (4.2.1) on=20
the console, because it has some crashing problem with the Riva128=20
graphics card. So, I tried two alternative solutions, both of which has=20
problems, and of which the latter is what I'd like to have somehow =

The first alternative is to run a windows-based X server on another box=20
(X-Win32), and using SSH with X11 forwarding to connect to the host.=20
This, beyond being quite slow, has a problem that when the virtual=20
VMware machine switches to a higher resolution than the default VGA one, =

the entire X server (on the windows machine) freezes, and the whole=20
session has to be killed.

My second solution attempt was to launch Xvnc on the NetBSD box, and=20
start VMware under that. The problem with this (the one I really want to =

have solved) is that I can only see anything when the guest os is in=20
text mode, as soon as it switches to *any* graphical video mode, I have=20
black screen in the VMware window. This includes VMware's boot screen=20
which is also graphical. I tried all the possible bit depths for the=20
Xvnc server, as well as a few pixel formats, all of which resulted in=20
the same black screen.

Any comments?