Subject: VMware vs. various X servers
To: None <>
From: Marton Fabo <>
List: tech-x11
Date: 07/17/2003 19:12:06

My problem may not be exactly XFree86-related, but falls still close, 
and perhaps someone around can suggest something.

So, the issue is the following. I'm trying to run VMware on a stock 
1.6.1 i386 machine. I can't run the provided XFree86 server (4.2.1) on 
the console, because it has some crashing problem with the Riva128 
graphics card. So, I tried two alternative solutions, both of which has 
problems, and of which the latter is what I'd like to have somehow solved.

The first alternative is to run a windows-based X server on another box 
(X-Win32), and using SSH with X11 forwarding to connect to the host. 
This, beyond being quite slow, has a problem that when the virtual 
VMware machine switches to a higher resolution than the default VGA one, 
the entire X server (on the windows machine) freezes, and the whole 
session has to be killed.

My second solution attempt was to launch Xvnc on the NetBSD box, and 
start VMware under that. The problem with this (the one I really want to 
have solved) is that I can only see anything when the guest os is in 
text mode, as soon as it switches to *any* graphical video mode, I have 
black screen in the VMware window. This includes VMware's boot screen 
which is also graphical. I tried all the possible bit depths for the 
Xvnc server, as well as a few pixel formats, all of which resulted in 
the same black screen.

Any comments?