Subject: Re: Help needed with NetBSD and XFree86 4.1/4.2/4.ANY
To: Randall Stewart <>
From: Richard Rauch <>
List: tech-x11
Date: 02/24/2002 14:16:36
> > Do you have a kernel with the INSECURE option turned on?  If not, are you
> > using the aperture driver?
> Yes, the INSECURE option is on.. This I found in the mailing archives..
> I must have fogot to put that down... Hmm but what is the aperture
> driver. Is this a kernel config option?
> > aperture is a LKM (Loadable Kernel Module), I gather.  You should be able
> > to find it somewhere in pkgsrc.

I've never installed aperture; you presumably will have to turn on LKM's
(off by default, I think; you will probably have to build a new kernel),
and do whatever the aperture documentation says you need to do.

> Sounds like I don't need it if I hae INSECURE on.. I am more
> than willing to get it though (if it will help :>)

At least one person has reported that he needs *both*, otherwise he gets
those bogus /dev/vga messages and X fails.  My understanding is that it's
normally a matter of which one you prefer...but apparently that's not
always the case.

> Well INSECURE is on so I will not bother with the aperture driver.

It wouldn't hurt to try it.

> > But, you probably need at least one of them to run X.  I do *not* think
> > that you should have, or should want, /dev/vga; apparently the X server
> > produces that as a bogus message if you don't have aperture or INSECURE.
> > (Or maybe installing aperture results in a proper /dev/vga?)
> Oh it is truely attempting to open /dev/vga. I have put printfs

I'm sure it is.  The point is that you shouldn't have created it (unless
doing so is part of the aperture LKM installation).

I don't have a /dev/vga; I never have had one.  XFree86 has worked nicely
for me on my desktop, tower, and laptop.

> all the way down through the mmap system following the function
> call chain down where the mmap call is failing. It ends up through
> the console driver at a function in vga.c vga_mmap() which will
> not work for i386.. this is what leads me to believe that either
> - I have a missing device in my configuration

No.  Not a standard one, anyway.

> - X has never worked for x86 (but that  MUST be wrong).

Works for me on PII, Athlon, and plain Pentium.  (^&

> >
> > Try removing the /dev/vga that you created, and turn on INSECURE if you
> > don't have it already.  If that still doesn't work, go get the aperture
> > driver.  (^&
> I have tried it both ways and no matter what the mmap call gets

???  You mean with INSECURE alone and with INSECURE + aperture?

(I get the impressin that you wrote this email in segments, so it's not
clear if you really decided against trying aperture.  I *really* think
that you should have done that as step #2.  In view of what one person has
told me, I'd try *both* at once, and if that works, see if you can turn

> If someone would be willing to share there kernel config
> with me .. maybe I could find what device I am missing.

I'm pretty sure that I've never had trouble getting X up on a GENERIC
kernel.  But I've used S3/S3V and Neomagic video hardware.

However, I'll send you my laptop's config via private email; I don't think
that it will help you at all, but you're welcome to look at it.  (^&

  ``I probably don't know what I'm talking about.''