Subject: Re: Help needed with NetBSD and XFree86 4.1/4.2/4.ANY
To: Richard Rauch <>
From: Randall Stewart <>
List: tech-x11
Date: 02/24/2002 05:25:03
Richard Rauch wrote:
> You didn't say if you've ever set up X before or not, or if you are new to
> NetBSD (two not necessarily related questions).  I will assume that you
> can find your way around, but have never set up X on any NetBSD system
> before.  I don't know how specific my comments are to the i386 port of
> NetBSD (or even whether any non-i386 ports use anything other than
> adapted/ported XFree86), so my comments may also be a bit provincial.

Well, I am quite familiar with the BSD's aka FreeBSD and Tahoe (from
way back). But this is my first fun with NetBSD.. I have setup
the XFree code in both linux and FreeBSD though..

> Do you have a kernel with the INSECURE option turned on?  If not, are you
> using the aperture driver?

Yes, the INSECURE option is on.. This I found in the mailing archives..
I must have fogot to put that down... Hmm but what is the aperture
driver. Is this a kernel config option?

I know INSECURE is on.. first thing I checked..

> My understanding is that you usually need *at*least* one of INSECURE or
> the aperture.  (One person was telling me that he needed both to get X to
> work on his card.)
> INSECURE is a kernel option.  If you are using a GENERIC kernel, the
> option should be enabled by default.  If you are using a custom kernel,
> you may have disabled this.

It is..

> aperture is a LKM (Loadable Kernel Module), I gather.  You should be able
> to find it somewhere in pkgsrc.

Sounds like I don't need it if I hae INSECURE on.. I am more
than willing to get it though (if it will help :>)

> My understanding is that some people didn't like the consequences of
> INSECURE, so they created the aperture driver.  Others have said that
> running aperture introduces exactly the same theoretical security problems
> as running INSECURE (i.e., no real benefit is realized by using aperture
> isntead of INSECURE).  I don't understand the technical issues well enough
> to have an opinion on that.

Well INSECURE is on so I will not bother with the aperture driver.

> But, you probably need at least one of them to run X.  I do *not* think
> that you should have, or should want, /dev/vga; apparently the X server
> produces that as a bogus message if you don't have aperture or INSECURE.
> (Or maybe installing aperture results in a proper /dev/vga?)

Oh it is truely attempting to open /dev/vga. I have put printfs
all the way down through the mmap system following the function
call chain down where the mmap call is failing. It ends up through
the console driver at a function in vga.c vga_mmap() which will
not work for i386.. this is what leads me to believe that either
- I have a missing device in my configuration
- X has never worked for x86 (but that  MUST be wrong).

> Try removing the /dev/vga that you created, and turn on INSECURE if you
> don't have it already.  If that still doesn't work, go get the aperture
> driver.  (^&

I have tried it both ways and no matter what the mmap call gets
made to Major device 47 Minor Device 4..which is actually
/dev/ttyE4. It does not matter if a device exists or not..

I have also tried at Stephen Ma's kind suggestion 

option "NoLinear" "on"
option "noMMO" "on"
option "NoINT10" "on"

and that does not work. I still see my printfs that show
me the mmap() chain is still being called down to the vga.c
which is guarenteed to return (-1) on all but the arc

If someone would be willing to share there kernel config
with me .. maybe I could find what device I am missing.


Randall R. Stewart 815-342-5222 (cell phone)