Subject: Re: Issues with NetBSD-current and XFree86 >= 4
To: Sean Davis <>
From: Florian =?iso-8859-1?Q?St=F6hr?= <>
List: tech-x11
Date: 06/24/2001 01:18:55
I always have the same problem with the original X version which comes with
NetBSD 1.5

with the I128 server, the system has exactly the same problem as you tell. Once
I played around a bit with the RAMDAC clock settings, then it worked.
Unfortunately, I ran XF86Config yesterday again to change mouse resolution ...
now I've got that console palette problem again. It's true, the problem doesn't
appear in FreeBSD. I'll play around with that RAMDAC settings again, this
should work.

Perhaps you try the same?


Sean Davis wrote:

> Hi, I'm having some really annoying problems with X on my NetBSD machine.
> The machine is a 533mhz Celeron, with 512MB of ram, and a Riva TNT2 Vanta
> AGP video card. I am leaning towards XFree86 4.x as opposed to 3.x because
> it performs far better on this machine (first tried XF86 4* in FreeBSD, but
> the speed improvement argument still holds true in NetBSD).
> I've built XFree86 4.1.0 from source and installed it, and as far as I can
> tell, everything works wonderfully, except for an oddity with wscons. When I
> start X, it comes up fine, I don't have any problems running it, but when I
> exit X and go back to console, my text display is about 2/3rds dimmer than
> it was before. If I go into and out of X again, I can't see console at all,
> and have to reboot if I want to see anything.
> I have tried XFree86 4.0.1, 4.0.2, 4.0.3, and now 4.1.0, and all four
> versions have the same problem. This issue wasn't present in FreeBSD, so my
> assumption is that it's something to do with wscons.
> Can anybody offer any ideas that might help?
> Thanks,
> -Sean