tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Addition of ppoll(2), a wrapper around pollts(2)

    Date:        Mon, 25 May 2020 06:06:09 +0200
    From:        Martin Husemann <>
    Message-ID:  <>

  | The man page diff does not suggest any standards that define this function.

It has been (twice now) proposed to posix to be added (both still pending,
linked as duplicate reports) and my guess is is quite likely to be added
in the next version.

In a different message said:

  | .. which is probably the worst name anyone could come up with.

That is similar to my comment in the POSIX issue list ... except that my
comment (while on the ppoll() issue) was directed at pselect() - ppoll()
as a name was chosen by analogy.  pselect() isn't going to change name now.


ps: no comments from me on the implementation issues - though I suspect
Martin's approach would probably be better - with the possible exception of
ever deleting the pollts() name, it has been around too long now for that
(but it could be implemented as a #define after the mythical libc bump).

Home | Main Index | Thread Index | Old Index