tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: adding getdelim(3) and getline(3) to libc

On Monday 13 July 2009 10:13:55 Alan Barrett wrote:
> On Sun, 12 Jul 2009, Roy Marples wrote:
> > The only issue is that getline collides with quite a few userland bits
> > such as ctags and nawk. I propose we change their internal definitons to
> > get_line, unless the really implement their own getline(3) and we can
> > just remove it.
> A couple of months ago, in response to a PR or a mailing list message
> about inability to build NetBSD on a host system that ahs POSIX
> getline(), I started experimenting with a semantic patch that was
> intended to rename getline to mygetline in cases where the usage was
> incompatible with POSIX.  It almost works but has some issues whose
> details I forget.

You wouldn't happen to recall the PR number by any chance?

BTW, I prefer get_line vs mygetline. Anyone else have a preference here?
I'd like to commit this rename tonight - I already have a patch prepared for 

I also think it would be a good idea to bump the version number to 5.99.16 
when getdelim/getline is committed, so that pkgsrc can depend on a specific 
NetBSD version for any fallout that will occur.



Home | Main Index | Thread Index | Old Index