tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: netbsd-5: another problem, news/leafnode + ioctl(SIOCGIFCONF)

 >>  >>leafnode-1.11.3nb1
 >> > change it to use getifaddrs().
 >> That is SIOCGIFCONF ioctl (or something else) is broken in netbsd-5
 >> and leafnode needs to be patched. Right?

> Wrong.  The calling program (leafnode) is broken -- it uses the ioctl
> wrong

Ok, if you say this you probably see where the problem is and can fix
it. Please describe what's the problem.
How about fixing a leafnode package?

> -- but the easiest way to fix it is to make it use getifaddrs
> instead of the ioctl. 
I see, getifaddrs API is available for very long time in *BSDs.
And in the future it makes sense for upstream to use it under BSDs.
But for now leafnode is shipped with pkgsrc as is and it doesn't work.

> Generally speaking netbsd-5 is much less tolerant of wrong application
> behavior than earlier releases of netbsd, usually because actually ensuring
> correct behavior in all cases for correct applications required this.

Best regards, Aleksey Cheusov.

Home | Main Index | Thread Index | Old Index