tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: obsoleting shlibs - what's the plan

Greg Troxel <> wrote:

> I just updated to 4.99.58 from 4.99.24 (!, long story, disk too small to
> build).  Mostly things are working fine.
> I updated using BUILD-NetBSD from etcmanage, and then ran 'postinstall
> fix obsolete'.  It deleted libraries that I think it shouldn't have:
>        Removed obsolete file /usr/lib/
> These are previous major versions of kerberos libraries.
> So, I think these shouldn't have been marked obsolete, and that in
> general that we should not obsolete previous major shlibs, just minor
> ones (e.g., if .so.3.1 arrives we can remove .so.3.0, but not .so.2.1).

You are correct, that's a bug.  Old heimdal shared libs shouldn't have
been marked obsolete.

SY, Uwe
--                       |       Zu Grunde kommen          |       Ist zu Grunde gehen

Home | Main Index | Thread Index | Old Index