Subject: Re: CVS commit: src/usr.bin/find
To: Perry E. Metzger <email@example.com>
From: SODA Noriyuki <firstname.lastname@example.org>
Date: 02/09/2007 02:09:07
>>>>> On Thu, 08 Feb 2007 11:37:48 -0500,
"Perry E. Metzger" <email@example.com> said:
>> So, we now reached the conclusion that current implementation
>> shouldn't have the name "-rm". Right?
> Only if it should not have the name "-delete" either. :)
It seems your opinion is:
1. "-rm" option should do what people expect.
and "-delete" option should be renamed.
2. "-delete" option remains as is.
and "-rm option remains as is.
I agree 1. is somewhat reasonable, although I believe 1 is not the way
to go (due to the compatibility reason with FreeBSD).
But 2 doesn't make any sense for me.
Because it leaves "-rm" option as the state no one (including you) wants.
Furthermore, it prevents "-rm" option from correctly being implemented,
because the correct implementation introduces insecure change.
Why do you want 2? I don't get it.
I think what we should do is:
3. leave "-delete" option as is (for the compatibility with FreeBSD).
Remove "-rm" option for now, so perhaps someone can implement
the "-rm" option with correct semantics later.
Although it's not sure whether the "-rm" option is really necessary
or not, as Hubert and David said.