Subject: Re: syslog_r (Re: CVS commit: src/lib/libc)
To: Christos Zoulas <>
From: SODA Noriyuki <>
List: tech-userlevel
Date: 10/26/2006 23:08:55
>>>>> On Thu, 26 Oct 2006 10:06:22 -0400, (Christos Zoulas) said:

> I think that it is useful for a program to be able to syslog()
> from an "unsafe" context. What do others think?

Even if that's useful, it's better to avoid the name like syslog_r(),
because the name implys that its format string is fully compatible
with syslog(), but actually it won't be compatible, as Thor said.