Subject: autoconf and m4 on netbsd-i386
To: None <,>
From: Kamal R. Prasad <>
List: tech-userlevel
Date: 02/04/2005 07:11:44

 I downloaded netbsd 2.0 src tree on an i386 system
running netbsd 2.0 (from the iso image). I did a
#./ distribution
#./ install=/

That presumably installed a perfect distribution of
netbsd 2.0. When I ran autoconf in src/gnu/dist/gcc, I
got an error:-
M4sugar requires GNU M4. Install it before installing
M4sugar or
set the M4 environment variable to its path name.
I commented out the #ifdeg ((__gnu__)) and did a
#export M4="m4 -g"

and it gave an error 
# autoconf -v
autoconf: running m4 -g -I /usr/local/share/autoconf
-I . -Dm4_tmpdir=/tmp/ac24018a -Dm4_warnings=syntax   
autoconf: forbidden:
autoconf: allowed: ^$

Can someone help me with getting autoconf+m4
functional on netbsd i386? It should be pretty
straightfwd if it is part of the distribution.


Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard.