Subject: gdb53 requires root priv?
To: None <>
From: None <>
List: tech-userlevel
Date: 10/03/2003 06:30:20
	with gdb53, i tried to trace normal binary as non-root user, and got
	"Couldn't get registers" error when i try to set breakpoint.  if i
	become root it runs okay.  is it a known issue?  previously gdb worked
	just fine with normal user.


itojun[starfruit:~/NetBSD/src/usr.bin/tftp] gdb obj.i386//tftp
GNU gdb 5.3nb1
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386--netbsdelf"...
(gdb) run
Starting program: /usr/home/itojun/NetBSD/obj/usr.bin/tftp.i386/tftp 
tftp> connect localhost
tftp: servname not supported for ai_socktype
tftp> ^D    
Program exited normally.
(gdb) break getaddrinfo
Couldn't get registers: Operation not permitted.