Subject: Re: NIS/YP interoperability (fwd)
To: None <>
From: Brandon D. Valentine <>
List: tech-userlevel
Date: 07/05/2000 17:01:46
I'm getting the impression that tech-userlevel is a better place for
this than tech-net.  I'm at my wits end here.  Since I wrote the message
below I've tried to configure a RedHat 6.1 box as a NIS client as well
with limited success.  The RH6.1 box was able to bind to the server only
when the server's hostname was manually specified in RH's /etc/yp.conf
file.  It would not find it via broadcast.  Once it was bound I was able
to ypcat files and ypwhich would return the hostname of the ss5.  I
don't see what could be preventing the IRiX clients from binding to this

Brandon D. Valentine
bandix at  |  bandix at
"Truth suffers from too much analysis." -- Ancient Fremen Saying

---------- Forwarded message ----------
Date: Wed, 5 Jul 2000 13:12:27 -0400 (EDT)
From: Brandon D. Valentine <>
To: David Brownlee <>
Subject: Re: NIS/YP interoperability

On Tue, 27 Jun 2000, David Brownlee wrote:

>	I used NetBSD as a ypserv slave in my last job witha bunch of IRIX
>	clients. I had to disable the 'secure password' map, but other
>	than that worked fine.

Hey David, perhaps you wouldn't mind looking over this for me then.
I've disabled the secure password map in the Makefile by setting
INSECURE to YES and that's no problem.  I've got an ss5 setup as the NIS
master with ypserv, ypbind, and rpc.yppasswdd running no problem.  I've
got an ss20 setup as the slave running ypserv and ypbind.  Both of these
sparcs are running NetBSD 1.5_ALPHA.  Both servers work very well as
clients but unfortunately not very well as servers thus far.  ypwhich on
both reports that they are using the ss5 as the master and they are able
to ypcat files to their heart's content.  However, when I try to attach
IRIX 6.x clients to them I get an error like this:

moray 85# domainname test
moray 86# ypwhich
Domain test not bound.

moray 89# domainname test
moray 90# ypset sponsz
ypset: Sorry, I can't make use of the NIS.  I give up.

These same clients work fine when a part of our existing NIS domain
being served off of an IRIX box that's about to go bye-bye.  Here's the
kicker though.  I got on one of the IRIX boxen and did "ypinit -s
master_server -d test" and it successfully transferred all of the maps
from the master server and started up ypserv in slave mode under IRIX.
Obviously it can speak NIS with the server.  After doing that I was able
to ypcat maps using localhost as the NIS server.  What is it preventing
IRIX clients from accessing the NetBSD NIS server purely as a client?
Is there some config option I need to mess with?

Brandon D. Valentine
bandix at  |  bandix at
"Truth suffers from too much analysis." -- Ancient Fremen Saying