Subject: Re: take2
To: None <>
From: Darren Reed <>
List: tech-userlevel
Date: 12/03/1999 09:17:03
Luke Mewburn writes:
> Darren Reed writes:
> > 6. I really don't like the current design for rc scripts with "start_cmd=",
> >    etc.  It unecessarily restricts an independant script on the contents of
> >    that script.  Each script should be run, not define variables which get
> >    executed.
> run_rc_command was initially developed as a method of reducing
> unnecessary code duplication in scripts (such as parsing command line
> arguments, checking for running processes, etc), and it does this
> well. You haven't explained very well what's wrong with run_rc_command
> in its role of supporting start/stop/... type operations.

1. It's immeadiately obvious with the solaris script what is happening,
   so debugging problems is that much easier.

2. In some of your rc scripts, you have start_cmd='\.  What happens when
   I want to use 's and "s as a part of a script ?  I need to go through
   stupid hoops for quoting.

3. It isn't immeadiately clear what `options' the netbsd dhcpd script
   supports (in terms of start/stop, etc).

4. On Solaris, init scripts are _independant_.  On NetBSD, for better or
   worse, they're all dependant on rc.subr providing functions.