Subject: Re: core dump filename format
To: Manuel Bouyer <email@example.com>
From: Jaromir Dolecek <firstname.lastname@example.org>
Date: 09/07/1999 16:28:32
Manuel Bouyer wrote:
> Following Bill Sommerfeld's idea of "core dump filename format",
> here is a more formal proposal:
> I propose to add a per-process inherited attribute, which would define
> the name of the core file.
> I can see 3 usefull formats:
> %n: name (argv) of the process
You mean process's p_comm value, right ? I guess it's not
worth the efford to find the argv.
> %p: the pid of the process
> %u: name of the user
Is the name available to the kernel somehow ?
> Idea for other formats are welcome.
I'd probably prefer something vaguely related to printf() format's,
i.e. %s for the name of process, %d for pid. Or avoid those funny
%foo altogether and use plain strings 'progname', 'pid',
'username'/'uid'. Consider how much more readable is
'progname-pid.core' than '%n-%p.core'.
> Comments ? I'm planning to start coding on this soon, shouldn't require
> much work.
IMHO it's a cool feature :)