Subject: Re: memsync() proposal (Was: Re: cacheflush() proposal)
To: Ignatios Souvatzis <is@jocelyn.rhein.de>
From: Jason Thorpe <thorpej@nas.nasa.gov>
List: tech-userlevel
Date: 02/07/1999 18:43:37
On Sun, 7 Feb 1999 13:32:10 +0100 
 Ignatios Souvatzis <is@jocelyn.rhein.de> wrote:

 > > DEFINITION (taken from eeh, enhanced by myself)
 > > 
 > > 	#include <sys/memsync.h>
 > > 
 > > 	void memsync(start, size, what), weakly aliased to
 > > 	void _memsync(start, size, what)
 > > 	void* start;
 > > 	size_t size;
 > > 	int what;
 > 
 > Should it really be void memsync(...)?

I really am bothered by the notion of naming this memsync() when the
ABI for at least one of our supported architectures REQUIRES that it
be called something else... So, what, are we going to provide that
symbol ONLY on that arch (MIPS), or are we also going to have that API
to this functionality available?

        -- Jason R. Thorpe <thorpej@nas.nasa.gov>