Subject: Re: NetBSD-1.3.2 Y2K problem
To: None <>
From: NG Yew Ban <>
List: tech-userlevel
Date: 10/08/1998 11:58:57
Dear Mr. Havard,

        I regenerated my kernel again and it still having error:-
1) I removed my compile directory
2) I ran "config YBNG in /sys/arch/i386/conf"
3) I checked /sys/arch/i386/compile/YBNG there is no pcppi.h
4) I created pcppi.h by "echo '#define NPCPPI
5) I ran "make depend"
6) I ran "make netbsd"

After I ran "make netbsd", there is an error came out:-

cc1: warning being treated as errors
.../sys/arch/i386/isa/clock.c    In function 'gettick'
.../sys/arch/i386/isa/clock.c     307     implicit declaration of function
.../sys/arch/i386/isa/clock.c     313     implicit declaration of function
Error code 1

Am I doing anything wrong or missing anything with applying clock.c 1.53?

-----Original Message-----
From: <>
To: <>
Cc: <>;
<>; <>; <>; <>
Date: Wednesday, October 07, 1998 4:42 PM
Subject: Re: NetBSD-1.3.2 Y2K problem

>         I downloaded the clock.c from
> and compile it, I get the error:- "pcppi.h not found", I check
> the clock.c code and there is a include header file #include
> "pcppi.h"
>         I downloaded the ls-lRA.gz from, gunzip
> it and I also can not find where is the location of pcppi.h

It's a generated header, generated by config on newer systems.
My corresponding header contains the following:

vader# cat /usr/src/sys/arch/i386/compile/SWAP/pcppi.h
#define NPCPPI  1

Apparently it has something to do with the PC speaker beeps.
There's probably just two values to try: 0 and 1, and I think in
your case I'd try 0 first, since the main objective is not to get
the PC to say "beep" but to test whether the clock is working
correctly in this particular corner case.

- Håvard