Subject: Re: NetBSD-1.3.2 Y2K problem
To: Christoph Badura <>
From: NG Yew Ban <>
List: tech-userlevel
Date: 10/03/1998 09:55:06
Dear Mr. Christoph,

My NetBSD-1.3.2 kernel configuration is GENERIC (default) and my localtime
zone /etc/localtime is soft link to GMT+8.

My Y2K test:-
1) Set the CMOS time to 31st Dec 1999  23:58:00pm
2) Boot into NetBSD-1.3.2
3) NetBSD-1.3.2 still show the date 31st Dec 1999 and finally it rolls over
to 1st Jan 2000, it is succeed !
4) I run "shutdown -r now" to reboot NetBSD
5) Without accessing CMOS and directly boot into NetBSD, I get the date 1st
Jan 1997 :(
6) I type "date" and I get 1st Jan 1997

Any idea?

Best Regards,

NG Yew Ban (
Technical Support Programmer
Computer Protocol Sdn. Bhd.
34, Jalan Berangan, 50200 Kuala Lumpur, Malaysia
Time Zone: GMT+8
Tel: (603) 2415232 (Hunting Line)   Fax: (603) 2418832
Netmeeting: (Cheaper !)
Personal Homepage:

-----Original Message-----
From: Christoph Badura <>
To: <>
Date: Saturday, October 03, 1998 12:21 AM
Subject: Re: NetBSD-1.3.2 Y2K problem

>>        I have a Y2K compliance clone PC and pass with NSTL YMARK2000 test
>>program (Version 97.08.15), whereas when I ran NetBSD-1.3.2, NetBSD-1.3.2
>>can roll over from year 1999 to year 2000, but after I rebooted the PC,
>>date reverted back to year 1997. (There is no multiboot program before
>>NetBSD booting).
>I don't understand what exactly the problem is.  Could you elaborate?
>Christoph Badura
>Verlag O'Reilly