Subject: Re: small hack
To: None <>
From: Christos Zoulas <>
List: tech-userlevel
Date: 09/24/1998 04:51:14
On Sep 23, 11:27am, ("Perry E. Metzger") wrote:
-- Subject: Re: small hack

| > 	- don't use errx in usage it would print the program name in usage
| > 	  twice; use fprintf("Usage: %s ...\n", __progname); I think at
| > 	  this point we should add a usage() function in libc that is
| > 	  printf like, since so many programs do this:
| I like the idea a lot, but could we call it something other than
| "usage" since the name "usage" is the one commonly used in existing
| programs and it would cause confusion? maybe "print_usage()" or
| something. We should also make sure gcc is taught how to find bugs in 
| its use (and in that of the warn* and err* functions if that isn't
| already done.)

This is the reason; to minimize the amount of diff.