Subject: RE: SCSI DAT tape drives.
To: None <, tech-userlevel@NetBSD.ORG>
From: None <>
List: tech-userlevel
Date: 03/11/1998 01:25:14
There has been an on-going discussion in the FreeBSD lists that this is
a problem with the Seagate firmware incorrectly supporting
tagged-command-queuing, in conjunction with how the ahc sequencer works.
Evidently, the problem is reproducible in NetBSD, FreeBSD, and Linux,
all OS' that use tagged-commands in their SCSI driver with the 2940.

You might surf the mailing list archives at .

I have had some problems myself.  I "resolved" them by using an older
drive on my NetBSD machine, and using my DDS-3 drive only on my NT
boxes.  Not exactly the fix I would prefer, but it allows me to get
backups for the time being.  Other proposed fixes are to disable
AHC_TAGENABLE in the kernel, or try a different SCSI controller (such as
a SymBIOS/NCR 53c8xx-based board).  However it sounds like you tried the
NCR route without success?

You can also try complaining to

> -----Original Message-----
> From:	Gerryt []
> Sent:	Wednesday, March 04, 1998 2:33 PM
> Arch: i386
> We have occasional backup problems with 4 mm DATS. What happens is we
> see this
> message:
> Mar  1 12:56:28 amon /netbsd: st0(ahc1:4:0):  Check Condition on
> opcode 0x1
> Mar  1 12:56:28 amon /netbsd:     SENSE KEY:  Unit Attention
> Mar  1 12:56:28 amon /netbsd:      ASC/ASCQ:  Power On, Reset, or Bus
> Device
> Reset Occurred
> When you see this message only a cold boot clears up the problem as
> tapes are
> no longer accesible.
> This is using an Adaptec 2940 UW controller. In the past we have tried
> changing:
> controller NCR to AHA
> scsi cable
> DAT drives
> OS upgrades from 1.2.1 to 1.3
> In short everything but the motherboard has been swapped out with
> different H/W
> or S/W. Still we see the above message at random times - approximately
> every
> 7-14 days. 
> Are all scsi tape drives this screwy? Do they work better if we say,
> give it
> its OWN controller?