tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Porting NetBSD to Eco32

On 08.09.2014 11:36, matthew green wrote:
> Alan Barrett writes:
>> On Sun, 07 Sep 2014, Jens Mehler wrote:
>>> The problem with
>>> nbmake:
>>> "/hdd/home/okarin/eco32/netbsd-on-eco32/usr/src/share/mk/"
>>> line 110: Wrong number of words (3) in .for substitution list with 2 vars
>>> still pops up.
>> BUILDSYMLINKS needs to contain an even number of "words", but it 
>> contains an odd number.  There's might be a "BUILDSYMLINKS += ..." 
>> line with only one file name instead of two, or (more likely) a 
>> "BUILDSYMLINKS += ..." line that uses variable expansion, and a 
>> variable is undefined or empty instead of containing the value you 
>> expect.  I would start by printing the unexpanded and expanded 
>> values of BUILDSYMLINKS using "make -V BUILDSYMLINKS" and "make -V 
>> '${BUILDSYMLINKS}'", and then track down how those values were 
>> set.
> this specific one happens when the mknative-gcc files aren't present.
> it might be nice to test it explicitly and error out with a nicer
> message..
> .mrg.
I am currently investigating why those files are missing.
I may have an idea that I am currently testing.
The README.mknative lists a few steps. (Sorry I am working on a really
old version : 6.0 - haven't got around to update to latest sources yet,
this will be done once we see the kernel in a stable state)

The following files are generated by bootstrap-libgcc:
eco32-make bootstrap-libgcc
Creating files needed for libgcc by a native bootstrap build.
external/gpl3/gcc/lib/libgcc/arch/ changed
external/gpl3/gcc/lib/crtstuff/arch/ changed
external/gpl3/gcc/lib/libgcc/libgcov/arch/eco32/ changed
external/gpl3/gcc/lib/libgcc/libgcov/arch/eco32/gcov-iov.h changed

eco32-make is just a symlink in my PATH.
I am not sure if that are all files but I proceeded with the next step:

4. At top level, do
   "nbmake-MACHINE do-distrib-dirs obj includes MKGCC=no MKBINUTILS=no".

back in the src/

do-distrib-dris runs without problems.
obj on the other hand resutls in

obj ===> external/gpl3/gcc/lib/libgcc/libgcc
line 110: Wrong number of words (1) in .for substitution list with 2 vars
nbmake: Fatal errors encountered -- cannot continue
nbmake: stopped in

Now I tried that part again

There is no output whatsoever :(

My next step would be to follow the build process of bootstrap-libgcc
and see what it does.
(I tried that a couple of months ago but with no result).

For now I assume the mistake is on my side because other arches build well.

With best regards,

Home | Main Index | Thread Index | Old Index