tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cross-building NetBSD-current on Mac OS X 10.5 (Leopard)

On Tue, Aug 16, 2011 at 06:15:33AM +0200, Alistair Crooks wrote:
> The attached, horrible, crufty and utterly uncleaned up diff will
> allow NetBSD-current to be cross-built on a Mac OS X Leopard machine
> (and, I think, anything with an OLD gcc, but untested on the same).

Well, the recent switch to GCC 4.5 effectively forces a cross-build from
Linux to have 32bit libraries e.g. for zlib on a 64bit host. I feel
that's adding a lot of additional dependencies just to workaround issues
in the build system. So is there any point in doing multilib builds for


Home | Main Index | Thread Index | Old Index