tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cross-building NetBSD-current on Mac OS X 10.5 (Leopard)


On Wed, Aug 17, 2011 at 04:24:11PM +0200, Hubert Feyrer wrote:
> No go. :(
> Running " -U -u -X ../xsrc-current -x -m i386 -T tooldir.Darwin -O 
> obj.i386-Darwin-XXX -D destdir.i386 -R release.i386 distribution"
> on "Darwin mini.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7 
> 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386"
> in src-current/tools/mpfr
> gives:
>       checking for recent GMP... yes
>       checking for __gmpz_init in -lgmp... no
>       configure: error: libgmp not found or uses a different ABI.
>       Please read the INSTALL file -- see "In case of problem".
> Full/more output is appended below.
Hm "ABI"! Just a shot in the dark: There is/was a problem with 64-bit-ABI 
versus 32-bit-ABI
documented in the bootstrap readme.macosx. Maybe "something" is build with the 
wrong ABI
"somewhere"? (Maybe I can try at home later...)


Home | Main Index | Thread Index | Old Index