tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Hashing support for make

On Sat, Apr 02, 2011 at 03:28:36AM +0200, Joerg Sonnenberger wrote:
 > the attached patch implements the :th modifier. It is intended to cut
 > down the output for MKREPRO=yes. This reduces the amount of IO for
 > verbose builds and also avoids copying data, so it should over all be at
 > least performance neutral.

Other than the name of the modifier, I like it.

As for the name of the modifier, how about just "hash"? While ~all of
the existing modifiers are cryptic, they're the names of operations
and transforms, and I think it's generally better for them to be like
function names than like sed commands.

Changing old ones is problematic, but I think ideally new ones should
be words.

David A. Holland

Home | Main Index | Thread Index | Old Index