tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index] install vs RO objdir/destdir

There's a 3.0 machine at work, on which I did a build of the 4.0 world
from source, via's build operation:

===> command: ./ -D /usr/local/4.0/build/DESTDIR -O 
/usr/local/4.0/build/OBJDIR -U build

This worked fine.  Today, I tried to install it into an alternative
boot disk with

./ -V USETOOLS=never -V 
TOOLDIR=/usr/local/4.0/build/OBJDIR/tooldir.NetBSD-3.0-i386 -D 
/usr/local/4.0/build/DESTDIR -O /usr/local/4.0/build/OBJDIR -U install=/mnt

The reason I'm writing is, this failed, because I had /usr/local/4.0
mounted read-only at the time (I have a log, which I can provide if
anyone wants).  It seems to me that an install of an already-built tree
should be something one can do read-only.

What's the thinking on this?  Am I confused in thinking this is a
reasonable thing to attempt?  Or is this a bug that I should send-pr?
Or is it something that ideally should be fixed but is currently more
work than it's worth?  Or what?

/~\ The ASCII                           der Mouse
\ / Ribbon Campaign
 X  Against HTML     
/ \ Email!           7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

Home | Main Index | Thread Index | Old Index