Subject: Re: CVS commit: src
To: None <>
From: Joerg Sonnenberger <>
List: tech-toolchain
Date: 07/03/2007 18:40:01
On Tue, Jul 03, 2007 at 09:30:56AM -0700, Matt Thomas wrote:
> >Log Message:
> >Rename nbinstall to ${MACHINE_GNU_PLATFORM}-install as it calls the
> >target strip. Don't pass down strip as it is not needed any longer.
> I don't see how this is any better than what was there previous.

The original version was:
- hard-wire /usr/bin/strip and pass in the toolchain strip via STRIP

The current version after this commit is:
- hard-wire toolchain strip and don't require any override

Without the rename it is impossible to relay on this behaviour and I
strongly believe that calling the correct strip is an implementation
detail of nbinstall and should not be exported via the calling
convention. This change makes the toolchain more self-contained in that
I can just call the install (e.g. from pkgsrc) and it does the right
thing and I don't have to worry about strip at all. This was what
triggered the change BTW.